Dica – Através de 1 Mikrotik faça Backup de TODOS os seus Mikrotik

Publicado por André Andrade em

MIKROTIK – Backup automático com armazenamento centralizado.

DICAS RECEITANET

Muitos nos perguntam como é possivel de 1 mikrotik central manter os backups dos outros servidores da rede.
Segue um passo a passo, para quem administra redes com muitos concentradores Mikrotik. Para escrever esse artigo,usamos como base a http://wiki.mikrotik.com/wiki/Automatic_Backup_with_Centralized_Storage_-_By_Ashish_Patel

Respeitando ao máximo os seus textos.

Devido as dificuldades de colocar para “rodar”, criamos o nosso script. 

Testado com Mikrotik versão 5.X. Funciona com qualquer versão acima de 2.X. (Não temos cliente com 2.Xpara testarmos). Aqui usamos Mikrotik virtualizado.

 

Backup automático com armazenamento centralizado.

Comas informações detalhadas aqui, agora é possível armazenar MikroTik Backupsroteador em um local centralizado. Isso pode ser feito automaticamente pelopróprio MikroTik Router usando os seguintes recursos.

1.Scripting

2.Scheduler

3.Fetch(introduzido na versão 3.x)

4.NTP

5.FTP

Suponha que temos uma grande rede conectada com um número de MikroTik Routers. É possível fazer um backup do sistema manualmente para cada roteador, mas isso se torna uma tarefa muito triste, onde você tem um grande número de roteadores e você precisa fazer o backup em uma base regular.

Exigência

MikroTikRouter OS v3.10 (ou superior) instalado na máquina baseada INTEL.

Usaremos essa máquina para o armazenamento de backup centralizado.

Primeiro de tudo configurar um servidor NTP no local centralizado e um cliente NTP em locais remotos, para que todos os sites (Mikrotik) são sincronizados com a mesma fonte tempo. Por sua vez, o local centralizado pode ser sincronizado comuma fonte de tempo mais precisos. Não vou explicar como se configura um servidor NTP. Para não fugir do artigo.

Segundo, 

FTP – Em IP SERVICES, tem que estar habilitado. Veja que por segurança podemos restringir qual ip ou range de ip poderá fazer uso do FTP. Caso não queirarestringir, não informe nada em Available From: vazio.

  • AMBIENTE EMPRESA-CLIENTE

Primeiracoisa, criar um agendamento para a criação automática dentro do própriomikrotik do nosso cliente.

SCRIPT:

No New Terminal(Copy e Paste)

/system script 

add name=backup_Diario source=”/system backup save name=backup_Diario”

A ideia do script é realizar o backup diariamente e que vá sendo sob-escrito todos os dias. Para não ocupar espaço dentro do Router Mikrotik.

Agendando o Backup

Agendamos o backup para que seja realizado 1 vez por dia, resolvemos que fosse as 5:00 da manha. Costuma ter menor tráfego.

SCRIPT:

No New Terminal(Copy e Paste)

/system scheduler

add disabled=no interval=1d name=BACKUP on-event=\

“system script run backup_diario”policy=\

ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive\

start-date=jan/01/2000 start-time=05:00:00

  • AMBIENTE MIKROTIKRIO

No servidor criado para guardar os Backups.

Aqui criamos a programação de buscar no servidor Remoto, salvar em nosso Servidor de armazenamento de Backups e organizarmos deforma a mantermos sempre 2 copias. Uma denominada dia PAR e outra denominada dia IMPAR. A fim de evitar acumulo de regras, criando um script e depois criando um agendamento como foi feito anteriormente. Resolvemos criar em apenas um lugar (/system scheduler) toda a logica. Facilitando o gerenciamento. Em FILES verá os Backup das empresas.

SCRIPT:

No New Terminal (Copy e Paste)

/system scheduler

add disabled=no interval=2d name=A-Backup-EMPRESA-xyz-Par on-event=”#Script-MIKROTIKRIO_V.1.\

4_Andre_Andrade\r\

\n/tool fetch address= IP_do_roteador_mikrotik_empresa-xyz user=USUARIOpassword=SENHAsrc-path=\”back\

up_Diario.backup\” mode=ftp dst-path=\”serverEMPRESA-xyz_PAR\””policy=\

ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \

start-date=nov/20/2000 start-time=05:30:00

add disabled=no interval=2dname=A-Backup-EMPRESA-xyz-Impar on-event=”#Script-MIKROTIKRIO_V.\

1.4_Andre_Andrade\r\

\n/tool fetch address= IP_do_roteador_mikrotik_empresa-xyz user=USUARIOpassword=SENHA src-path=\”back\

up_Diario.backup\” mode=ftpdst-path=\”serverEMPRESA-xyz_IMPAR\””policy=\

ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api\

start-date=nov/21/2000 start-time=05:30:00

OBS:

O que esta em negrito e italico deverá ser inserida as informações do vosso cenário.

Exemplo de Aplicação:

SCRIPT:

No New Terminal(Copy e Paste)

/system scheduler

add disabled=no interval=2d name=A-Backup-INTERHOME-PAR on-event=”#Script-MIKROTIKRIO_V.1.\

4_Andre_Andrade\r\

\n/tool fetch address=172.16.254.200 user=12345678 password=admin src-path=\”back\

up_Diario.backup\” mode=ftpdst-path=\”server-INTERHOME-PAR\””policy=\

ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \

start-date=nov/20/2000 start-time=05:30:00

add disabled=no interval=2d name=A-Backup-INTERHOME-IMPAR on-event=”#Script-MIKROTIKRIO_V.\

1.4_Andre_Andrade\r\

\n/tool fetch address=172.16.254.200 user=admin password=12345678 src-path=\”back\

up_Diario.backup\” mode=ftpdst-path=\”server-INTERHOME-IMPAR\””policy=\

ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \

start-date=nov/21/2000 start-time=05:30:00

OBS:

O que esta em negrito e itálico deverá ser inserida as informações do vosso cenário.

Espero que a contribuição ajude a todos. 

Peço que não seja retirado os créditos a fim de incentivar a publicação de mais ferramentas.

https://under-linux.org/showthread.php?t=169589&p=688866#post688866

Fonte: https://www.facebook.com/notes/mikrotik-rio-brasil/dica-23-mikrotik-atrav%C3%A9s-de-1-mikrotik-fa%C3%A7a-backup-de-todos-os-seus-mikrotik/550871755001092 acessado em 25/07/2018 as 13:30

Equipe ReceitaNet – Sempre trabalhando para o seu Crescimento!


André Andrade

Pós Graduação em Engenharia de Redes e Sistemas de telecomunicações - Inatel